Apple - Is there a way to see System Information before first user is added?

The following assumes that the Recovery HD has the same version of macOS installed on the Macintosh HD for the accuracy of OS version information.

If you boot the Mac to Recovery Mode, you can access System Information from Terminal using the following command, e.g.:

/Volumes/Macintosh\ HD/usr/sbin/system_profiler

You might what to minimize the output and use and of the following options:

  • -listDataTypes - Lists the available datatypes.
  • -detailLevel level - Specifies the level of detail for the report:
    • mini - Report with no personal information.
    • basic - Basic hardware and network information.
    • full - All available information.

To get just a Hardware: report, use:

  • SPHardwareDataType

Example:

/Volumes/Macintosh\ HD/usr/sbin/system_profiler SPHardwareDataType

On my system the outout of the above command was:

Hardware:

    Hardware Overview:

      Model Name: MacBook Pro
      Model Identifier: MacBookPro10,1
      Processor Name: Intel Core i7
      Processor Speed: 2.8 GHz
      Number of Processors: 1
      Total Number of Cores: 4
      L2 Cache (per Core): 256 KB
      L3 Cache: 8 MB
      Memory: 16 GB
      Boot ROM Version: MBP101.00EE.B12
      SMC Version (system): 2.3f36
      Serial Number (system): <Information omitted for security reasons.>
      Hardware UUID: <Information omitted for security reasons.>

Notes:

To boot to the Recovery HD, press CommandR when booting the Mac. See also About macOS Recovery

Also, have a look at the manual page for system_profiler

If you want to just get information for some of the -listDataTypes listed, you can add each on the command line, e.g.:

/Volumes/Macintosh\ HD/usr/sbin/system_profiler SPHardwareDataType SPSoftwareDataType

The system_profiler command can be run directly from single-user mode, by pressing CommandS when booting the Mac, without having to provide the fully qualified pathname, however depending on how much information you want from system_profiler, you may need to pipe the output to more to less, etc., as scrolling in single-user mode is not as easy as from Terminal when booted to the Recovery HD.

That said, if all you want is the basic output shown under Hardware: and Software: from using the system_profiler command, then use the following command in single-user mode:

system_profiler SPHardwareDataType SPSoftwareDataType

Note that the software info from single-user mode is that which is install on the Macintosh HD, unlike from the Recovery HD it's that of the OS X Base System and while it should be the same, it may not. The hardware info is accurate in either case.


In my case system_profiler would not load (Abort trap: 6), and sw_vers only shows the OS version. I needed the processor, memory and disk details.

Boot into Recovery Mode, holding Command+R at boot. Then go into Utilities > Terminal

Processor

$ sysctl -n machdep.cpu.brand_string
Intel(R) Core(TM) i5-5257U CPU @ 2.70GHz

Memory

$ sysctl -n hw.memsize
17179869184

16 GB RAM = 17179869184 / 1024 / 1024 / 1024

Disk Space

$ diskutil list
/dev/disk1 (internal):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         500.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk1         500.0 GB   disk0s2

500 GB


Easy - boot to single-user mode and then shut down.

  1. Hold S key while booting (if you miss when the chime starts and the setup assistant runs - quit and shut down).
  2. When the black screen shows white text - wait for it to stop and type sw_vers.
  3. Once you’ve recorded the information, type halt.

You can use sw_vers in any mode. Its output looks like this:

$ sw_vers 
ProductName:    Mac OS X
ProductVersion: 10.13.1
BuildVersion:   17B1003