libgtk-3-0 dependency issues

Ok, if you are still experiencing this problem, it happens because some package won't work if the versions of their peers aren't the same.

libgail-3-0 : Depends: libgtk-3-0 (= 3.6.0-0ubuntu3.2) but 3.6.0-0ubuntu3.1 is installed
libgtk-3-0 : Depends: libgtk-3-common (= 3.6.0-0ubuntu3.1) but 3.6.0-0ubuntu3.2 is installed
libgtk-3-bin : Depends: libgtk-3-0 (>= 3.6.0-0ubuntu3.2) but 3.6.0-0ubuntu3.1 is installed

As you can see libgail-3-0 requires libgtk-3-0 to be 3.6.0-0ubuntu3.2 but libgtk-3-0 requires libgtk-3-common to be 3.6.0-0ubuntu3.1 a diference of .1 versions. So, since libgtk-family can't be of different versions, apt-get gets an expectacular dependency error. So how to solve this? We use the hold package status:

echo "libgtk-3-bin hold" | sudo dpkg --set-selections
echo "libgtk-3-0 hold" | sudo dpkg --set-selections

With this, you can upgrade normally until the dependency conflicts get resolved in the Ubuntu repositories.

Once you feel that you can allow upgrades, just run:

echo "libgtk-3-bin install" | sudo dpkg --set-selections
echo "libgtk-3-0 install" | sudo dpkg --set-selections

Another option is to force versions to being installed:

sudo apt-get update
sudo apt-get install libgtk-3-0=3.6.0-0ubuntu3.1 libgtk-3-common=3.6.0-0ubuntu3.1 libgtk-3-0=3.6.0-0ubuntu3.1

This will tell apt-get to install everything using the same version number.