Java: pseudo-setter method for immutable classes

I would call it withX(value). It says that it will be something with x = value.

If the class had a lot of fields, I would be afraid of:

obj.withX(1).withY(2).withZ(3).withU(1)...

So I would maybe use the builder pattern—introduce a mutable variant of the given class with only data and methods to create the original class with its current state. And there I would call these methods x(), y(), z(), and make them return this. So it would look like:

Immutable im2 = new Mutable(im1).x(1).y(2).z(3).build();

Original article: Immutable Setters: Naming Conventions (from Programming.Guide)


withX(...)

This is the de facto standard naming convention for immutable setters. This is for example the default name for setters generated by the Immutables framework. Here's an example:

Foo newFoo = foo.withX(1047);

There is a @Value.Style option to change this pattern, but the option itself is called with="...", which emphasizes what the default convention is.

Being the most widespread convention, it's easy to find examples of this. Guava and the Java time package being two.

Just x(...)

Another approach is to not have a prefix at all. You see this in for example builders generated by the Immutables framework:

Foo foo = ImmutableFoo.builder()
                      .x(1047)
                      .y("Hello World")
                      .build();

If you use this approach directly on the immutable class (that is, no builder involved) you'd typically have it as an overload to the getter:

Foo newFoo = foo.x(5);  // setter - one argument
int x = newFoo.x();     // getter - no arguments

This convention is used in for example the Java Spark framework.

setX(...)

Some APIs use the same naming convention as for setters in mutable classes. This has the obvious drawback that it can be surprising when you're new to a code base. Working with BigInteger and writing…

bigInt.setBit(2);

…would for example be a mistake, since the returned object is discarded. With this naming pattern you have to get used to writing

BigInteger newBigInt = bigInt.setBit(2);

deriveX(...)

To highlight the fact that the new value is derived from the existing object, you could use deriveX(...). The immutable Font class in the Java API follows this pattern. If you want to create a new font with, for example, a specific size you use

Font newFont = font.deriveFont(newSize);

The Font class has been around since the beginning of time. This convention is not very common as of today.

Immutable object being an operand

When the immutable object is itself an operand to the transformation it's not really a setter in the traditional sense, and there's no need to have a prefix for the method. For example…

BigDecimal newBigDec = bigDec.multiply(BigDecimal.TEN);

…has the same signature as a setter, but multiply is clearly a better method name than any other alternative.

Same with String.substring, Path.resolve, etc.


withX() sounds OK because it's a convention used for some Builder patterns.

This is more of a "partial clone" or "builder" than a "setter"...

If you look at java.lang.String (also immutable) there are all sorts of methods that return a new String based on the old one (substring, toLowerCase(), etc)...

Update: See also answer from aioobe [deriveFoo()] which I like - it's perhaps clearer, especially to anyone not familiar with Builder patterns.


It's definately not a setter, since it actually constructs and returns a new object. I think the factory semantics would be the more appropriate option in this case

public Foo newFooWith(int x) {
   return new Foo(x, other);
}

The alternative might be a variant of the copy constructor

class Foo {
    public Foo(Foo foo, int x) {
      return new Foo(x, foo.getOtherStuff());
    }
}