Is there a compatibility list for Angular / Angular-CLI and Node.js?

|Angular CLI|       Angular      |            NodeJS            |TypeScript |
|-----------|--------------------|------------------------------|-----------|
|-          |2.x                 |6.0.x or later minor          |2.0.x      |
|1.0.6      |4.x                 |6.9.x or later minor          |2.2.x      |
|1.1.3      |4.x                 |6.9.x or later minor          |2.3.x      |
|1.2.7      |4.x                 |6.9.x or later minor          |2.3.x      |
|1.3.2      |4.2.x or later minor|6.9.x or later minor          |2.4.x      |
|1.4.10     |4.2.x or later minor|6.9.x/8.9.x or later minor    |2.4.x      |
|(1.5.6)    |5.0.x               |6.9.x/8.9.x or later minor    |2.4.x      |
|1.5.6      |5.1.x               |6.9.x/8.9.x or later minor    |2.5.x      |
|1.6.7      |5.2.x or later minor|6.9.x/8.9.x or later minor    |2.5.x      |
|1.7.4      |5.2.x or later minor|6.9.x/8.9.x or later minor    |2.5.x      |
|6.0.8      |6.0.x               |8.9.x or later minor          |2.7.x      |
|6.1.5      |6.1.x               |8.9.x or later minor          |2.7.x      |
|6.2.9      |6.1.x               |8.9.x or later minor          |2.9.x      |
|7.0.7      |7.0.x               |8.9.x/10.9.x or later minor   |3.1.x      |
|7.1.4      |7.1.x               |8.9.x/10.9.x or later minor   |3.1.x      |
|7.2.4      |7.2.x               |8.9.x/10.9.x or later minor   |3.2.x      |
|7.3.9      |7.2.x               |8.9.x/10.9.x or later minor   |3.2.x      |
|8.0.6      |8.0.x               |10.9.x or later minor         |3.4.x      |
|8.1.3      |8.1.x               |10.9.x or later minor         |3.4.x      |
|8.2.2      |8.2.x               |10.9.x or later minor         |3.4.x      |
|8.3.25     |8.2.x               |10.9.x or later minor         |3.5.x      |
|9.0.7      |9.0.7               |10.13.x/12.11.x or later minor|3.6.x/3.7.x|
|9.x        |9.x                 |10.13.x/12.11.x or later minor|3.6.x-3.8.x|
|10.x       |10.x                |10.13.x/12.11.x or later minor|3.9.x      |
|10.1.x     |10.1.x              |10.13.x/12.11.x or later minor|3.9.x/4.0.x|
|10.2.x     |10.2.x              |10.13.x/12.11.x or later minor|3.9.x/4.0.x|
|11.0.7     |11.0.x              |10.13.x/12.11.x or later minor|4.0.x      |
|11.1.x     |11.1.x              |10.13.x/12.11.x or later minor|4.0.x/4.1.x|
|11.2.x     |11.2.x              |10.13.x/12.11.x or later minor|4.0.x/4.1.x|

ref: https://gist.github.com/LayZeeDK/c822cc812f75bb07b7c55d07ba2719b3


I acknowledge that this does not actually answer your question. But it does provide some relevant information for current version (which is what brought me here).

Here is the official word from Angular on current version:

https://angular.io/guide/setup-local

"Angular requires a current, active LTS, or maintenance LTS version of Node.js."

In the notes you will see a link to a package.json file that contains an "engines" section. For Angular 11 it says:

  "engines": {
    "node": ">= 10.13.0",
    "npm": ">= 6.11.0",
    "yarn": ">= 1.13.0"
  },

It might be possible to look at the released version of package.json in GitHub and determine the engines.node setting?