Function naming conventions

One of the more universal, yet simple rules is: Function names should be verbs if the function changes the state of the program, and nouns if they're used to return a certain value.


One more important thing to do when writing a library is to use the same word to describe the same action every time. don't write a function named getName in one class and another function named retrieveNumber in another class.


Have a look at

  • Naming Conventions for .NET / C# Projects
  • Naming Guidelines