Apple - Creating A Bootable USB Of Windows 8.1 On OS X?

I am not really sure why you would want to install Windows 8.1 without BootCamp.

The USB stick needs to be a little bigger than the .iso file you are going to be burning. It doesn't matter if there is any data on it, this will totally erase the whole thing.


Steps To Achieve Victory

  1. Download the ISO you want to use
  2. Open Terminal (in /Applications/Utilities)

    2.1 Navigate to the path where the .iso file is located

    2.2 Use ls to list all the folders

    2.3 cd /path/to/iso to dive in to folder or cd .. to go back the path

  3. Convert .iso to .img using hdiutil:
    hdiutil convert -format UDRW -o /path/to/target.img /path/to/source.iso
  4. Rename if OS X gave it a .dmg ending:
    mv /path/to/target.img.dmg path/to/target.img
  5. Type diskutil list to get a list of currently connected devices
  6. Insert USB drive you want to use
  7. Run diskutil list again to see what your USB stick gets assigned eg - /dev/disk3
  8. Run diskutil unmountDisk /dev/diskN (where N is the number assigned to your USB stick, in previous example it would be 3)
  9. Run sudo dd if=/path/to/target.img of=/dev/diskN bs=1m (if you get an error, replace bs=1m with bs=1M
  10. Run diskutil eject /dev/diskN and remove your USB stick
  11. The USB stick will now be ready to use

IMPORTANT For the step #9 you can use the destination to /dev/rdiskN to reduce the copy time.

NOTE: Sometimes, not always, Step #4 will be necessary. Not all the time. I am not sure why it will add the .dmg ending and other times leave it alone.

NOTE 2: Might I suggest you learn the name of the .iso you downloaded, or just rename it win8.1.iso or something, and put it on your Desktop folder. That way, when you are typing commands like #3 and #4 etc, etc, you can type it like this:

hdiutil convert -format UDRW -o ~/Desktop/win8.1.img ~/Desktop/win8.1.iso

and

mv ~/Desktop/win8.1.img.dmg ~/Desktop/win8.1.img

and step #9 would look like this:

sudo dd if=~/Desktop/win8.1.img of=/dev/diskN bs=1m

IMPORTANT - You can track the progress by pressing CTRL + T It will show the process info and records in and out, since we use the bs=1m each record is 1Mb in size so you can easily track the progress.


I don't mean to be insulting with Note and Note2, I am just making sure that you know what all these commands mean. It's the simplest method. Unless someone else comes up with something better.


I would have liked to comment on the previous answer, because it's a (nearly) perfect description of what to do (at least for the Linux distros I've been working through over the past week), but I'm shy of the 50 rep needed for comments…

Anyway, to supplement @danijel-j's answer, I discovered that (some?) of the USB keys I was using required me to partition them before the BIOS on the netbook I was working with would recognize them (presumably they had no MBR/GPT for the machine to read). I did the partitioning with Disk Utility.app, but I'm sure working through it with diskutil would be just as easy (I still don't know the CLI commands and options for diskutil).


This is terrible, but abandon all efforts to create this from OSX Mojave 10.14.4. I tried all the methods, I am a proficient power user and nothing worked. While I was continuously able to create a bootable usb drive, it failed on the windows installation with A media driver your computer needs is missing.

I verified the downloaded iso, redownloaded etc, to no avail.

What did work:

Boot into parallels in a windows os, use the windows media creation tool and create the usb drive.

Booted, installed without issue.

TL;DR it is absolutely ridiculous that you cannot use osx native commands to make this work, but clearly Microsoft has failed to make this process easy from a mac. Use the windows media creation tool from any available windows os, including parallels will get you a bootable usb that will install without driver problems.