Apple - Copying ISO file to USB drive in OS X?

IMHO the easiest way is in terminal:

  • First run diskutil list
  • then insert your usb stick
  • and run diskutil list again to see the disk node (e.g. /dev/disk2).
  • Now run diskutil unmountDisk /dev/diskN
  • and do sudo dd if=/path-to.iso of=/dev/rdiskN bs=1m (or bs=1M with homebrew)
  • When finished diskutil eject /dev/diskN

From http://www.youtube.com/watch?v=fu2g_E2ZK8A:

Screen shot from video

You can also can try this. It works for me. This is a rather "raw" copy and will typically not work for a bootable USB, but will work for other cases.

Here is a transcription of the commands from the screen shot for your copy/paste pleasure.

diskutil list                                            # shows disks
hdiutil convert -format UDRW -o destino.img origen.iso   # convert to dmg
sudo dd if=destino.img.dmg of=/dev/rdisk1 bs=1m          # copy to USB on rdisk1

If you want your USB to be "bootable" when all is said and done (ex: windows install disk), you're going to either want to use the Boot Camp Assistant (only check the "Create a Windows 7 or later version install disk" checkbox, then follow the prompts, it will create a FAT32 (i.e. bootable) USB version of your ISO file).

Some ISO's are created "special" to not need this, but not all are (ex: windows install disks). Details: https://superuser.com/q/1063220/39364

I.e. dd is not always enough. Especially for windows install .iso's.

Tags:

Unix

Macos

Usb

Iso